Alvorlig sikkerhetshull i Linux

Alvorlig sikkerhetshull i Linux

Det er funnet flere sikkerhetshull i Linux som lar inntrengeren ta over kontrollen av maskinen.
Utviklere advarer nå mot flere sikkerhetshull Linux. Det skal dreie seg om svakheter i to komponenter som begger åpner operativsystemet for angrep. Angriperne kan åpne disse hullene ved at de lurer brukeren til å åpne et bilde eller en komprimert fil, dette melder Idg.se.

Problemet ligger i Imlib som er et bibliotek for grafikktilpasninger i Gnome-miljøet (et av de mest brukte grafiske grensesnittene i Linux), den inneholder en feil som tillater at skadelig kode kan kjøres når brukeren åpner et spesielt utformet bitmap-bilde. Det sier Marcus Meissner i Novell til IDGs egen nyhetstjeneste.

Patcher som fikser problemet kan lastes ned hos Mandrakesoft, Gentoo og andre Linuxdistributører.

Red Hat advarer også om tre sikkerhetshull i LHA, som er et verktøy for å pakke/pakke opp arkiv i LHAc-format. Feilene påvirker alle versjoner opp til 1.14 og gjør det mulig å kjøre skadlig kode ved at brukeren pakker opp en infisert fil.

Før eventuelle patcher er installert, sier ekespertene at den beste måten å beksytte seg er å unngå å pakke opp ukjente filer.