<!DOCTYPE html> <html lang="no" dir="ltr" xmlns:ng="https://angularjs.org" id="ng-app" ng-app="newsfront" class="ng-scope"><head><style type="text/css">@charset "UTF-8";[ng\:cloak],[ng-cloak],[data-ng-cloak],[x-ng-cloak],.ng-cloak,.x-ng-cloak,.ng-hide{display:none !important;}ng\:form{display:block;}.ng-animate-block-transitions{transition:0s all!important;-webkit-transition:0s all!important;}</style>
  <base href="/">
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">

  <link rel="alternate" type="application/rss+xml" title="RSS" ng-href="https://admin.cw.no/rss.xml" href="https://admin.cw.no/rss.xml">
  <link rel="icon" href="/sites/computerworld/img/favicon/16x16-favicon.png" sizes="16x16" type="image/png">
  <link rel="icon" href="/sites/computerworld/img/favicon/32x32-favicon.png" sizes="32x32" type="image/png">
  <link rel="icon" href="/sites/computerworld/img/favicon/64x64-favicon.png" sizes="64x64" type="image/png">

  <!-- FB OG -->
  <meta property="og:title" content="Apple fikser Spectre og Meltdown | Computerworld">
  <meta property="og:image" content="http://static.cw.newsfront.no/sites/default/files/styles/full/public/img/spectre.png">
  <meta property="og:site_name" content="Computerworld">
  <meta property="og:url" content="http://www.cw.no/artikkel/apple/apple-fikser-spectre-meltdown">
  <meta name="description" property="og:description" content="De alvorlige lavnivå-svakhetene i Intels og andres prosessorer har konsekvenser for datamaskiner siden forrige århundre. Apple har tatt grep, og det ser ut til at selskapets produkter ikke vil oppleve de samme ytelsesreduksjonene andre plattformer kommer til å oppleve.">
  <meta name="author" content="Arno Vaa">

  <!-- Twitter Meta -->
  <meta name="twitter:card" content="summary">
  <meta name="twitter:site" content="@ComputerworldNO">
  <meta name="twitter:title" content="Apple fikser Spectre og Meltdown | Computerworld">
  <meta name="twitter:description" content="De alvorlige lavnivå-svakhetene i Intels og andres prosessorer har konsekvenser for datamaskiner siden forrige århundre. Apple har tatt grep, og det ser ut til at selskapets produkter ikke vil oppleve de samme ytelsesreduksjonene andre plattformer kommer til å oppleve.">
  <meta name="twitter:image" content="http://static.cw.newsfront.no/sites/default/files/styles/full/public/img/spectre.png">

  <title>Apple fikser Spectre og Meltdown | Computerworld</title>
  <link href="//cloud.webtype.com/css/3fbbf615-718f-48fa-816c-bd86c9440257.css" rel="stylesheet" type="text/css">
  <link href="//fonts.googleapis.com/css?family=PT+Serif:400,700,400italic,700italic" rel="stylesheet" type="text/css">

  <link href="/sites/computerworld/css/icons.css?1511346269" rel="stylesheet">
  <link href="/css/computerworld.css?1511346269" rel="stylesheet">
  <link href="/css/print.css?1511346269" rel="stylesheet" media="print">


  <!-- CW Bilag -->
  <script async="" src="//www.googletagmanager.com/gtm.js?id=GTM-5LSSKW"></script><script>
    if(-1 < ['bilag.cw.no', 'bilag.cw.newsfront.no', 'cwads.newsfront.local']
    .indexOf(window.location.host)) { window.cwBilag = true; }
  </script>

  <!--[if lte IE 8]>
    <link rel="stylesheet" type="text/css" href="/sites/default/css/ie.css" />
    <script src="/js/legacy/respond.min.js"></script>
    <script src="/js/legacy/html5shiv.js"></script>
  <![endif]-->
  <!--[if lt IE 10]>
    <script src="/js/legacy/xhr-xdr-adapter.js"></script>
  <![endif]-->

  <!-- Piwik -->
  <script type="text/javascript">
    if(navigator.userAgent !== 'NewsPhantom') {
      var _paq = _paq || [];
      _paq.push(["enableLinkTracking"]);
      _paq.push(["setTrackerUrl", "https://stats.newsfront.no/piwik.php"]);
      _paq.push(["setSiteId", "8"]);
      document.write('<scr'+'ipt type="text/javascript" defer="" async="" src="//stats.newsfront.no/piwik.js"></scr'+'ipt>');
    }
  </script>
  <!-- End Piwik Code -->

  <!-- Google Analytics -->
  <script>
    if(navigator.userAgent !== 'NewsPhantom') {
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-50963599-1', 'auto');
      ga('create', 'UA-50963599-5', 'auto', {'name': 'itbTracker'});
      ga('create', 'UA-50963599-4', 'auto', {'name': 'mcwTracker'});
      ga('create', 'UA-50963599-3', 'auto', {'name': 'pcwTracker'});
      ga('create', 'UA-50963599-6', 'auto', {'name': 'idgTracker'});
      ga('require', 'displayfeatures');
    }
  </script>
  <!-- End Google Analytics -->

  <!-- Link Pulse -->
  <script type="text/javascript">
    if(navigator.userAgent !== 'NewsPhantom') {
      document.write('<scr'+'ipt type="text/javascript" src="http://ll.lp4.io/app/53/7f/15/537f1529e45a1db9506d8d3f.js"></scr'+'ipt>');
    }
  </script>
  <!-- End LinkPulse -->

  <!-- Cxense script begin -->
  <script type="text/javascript">
  if(navigator.userAgent !== 'NewsPhantom') {
    var cX = cX || {}; cX.callQueue = cX.callQueue || [];
    cX.callQueue.push(['setSiteId', '1145204478274472326']);
    cX.callQueue.push(['sendPageViewEvent']);

    (function(d,s,e,t){e=d.createElement(s);e.type='text/java'+s;e.async='async';
    e.src='http'+('https:'===location.protocol?'s://s':'://')+'cdn.cxense.com/cx.js';
    t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(e,t);})(document,'script');
  }
  </script>
  <!-- Cxense script end -->
</head>
<body data-status="ready" ng-class="{'exp-menu-open': showExpMenu, 'user-menu-open': showUserMenu}">
<!-- Google Tag Manager -->
<noscript>&lt;iframe src="//www.googletagmanager.com/ns.html?id=GTM-5LSSKW"
height="0" width="0" style="display:none;visibility:hidden"&gt;&lt;/iframe&gt;</noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5LSSKW');</script>
<!-- End Google Tag Manager -->

  <!-- EXPANDED MENU OVERLAY -->
  <div class="expanded-menu-overlay" ng-click="toggleExpMenu()"></div>

  <!-- Bigboard -->
  <div class="cw-bigboard">
    <div class="big-wrapper">
      <div idg-ad="" position="Bigboard" responsive="true" mq="(min-width:1215px)" class="ng-isolate-scope"></div>
    </div>
  </div>
  <div class="cw-bigboard-companion">
    <div class="companion-wrapper">
      <div idg-ad="" position="Bigboard_Companion" responsive="true" mq="(max-width:1214px)" class="ng-isolate-scope"></div>
    </div>
  </div>

  <!-- AD "Leaderboard_Forside_980x150" -->
  <div class="cw-ad-wrapper ng-isolate-scope" idg-ad="" position="Leaderboard_980x150" target="desktop"></div>
  <!-- AD "Leaderboard_Tablet" -->
  <div class="cw-ad-wrapper ad-responsive x-980-150 ng-isolate-scope" idg-ad="" position="Leaderboard_Tablet" target="tablet" responsive="true"></div>

  <!-- MAIN MENU -->
  <header class="cw-header">
    <div class="cw-wrapper clearfix">
      <nav class="mobile-menu">
        <ul>
          <li class="keep-mobile ng-hide" ng-show="showExpMenu">
            <a href="" ng-click="toggleExpMenu()"><i class="i-cancel"></i><span class="visuallyhidden">Close</span></a>
          </li>
          <li class="keep-mobile" ng-show="!showExpMenu">
            <a href="" ng-click="toggleExpMenu()"><i class="icon-menu"></i><span>Meny</span></a>
          </li>
        </ul>
      </nav>

      <nav class="main-menu">
        <ul>
          <li><a href="" ng-click="toggleExpMenu()"><i class="icon-menu"></i><span class="visuallyhidden">Meny</span></a></li>
          <li><a href="" ng-click="toggleSearch()"><i class="icon-search"></i><span class="visuallyhidden">Søk</span></a></li>
          <li class="keep-mobile"><a href="" ng-click="toggleUserMenu()"><i class="icon-user"></i><span class="visuallyhidden">Bruker</span></a></li>
        <ul>
      </ul></ul></nav>

      <div class="mobile-logo"><a cw-href="/" class="ng-isolate-scope" href="/">CW</a></div>
      <div class="logo white">
        <a cw-href="/" class="ng-isolate-scope" href="/"><img src="/sites/computerworld/img/main-logo.png" alt="Computerworld"></a>
      </div>

      <nav class="text-menu">
        <ul>
          <li><a cw-href="/emne/ehelse" class="ng-isolate-scope" href="/emne/ehelse">E-helse</a></li>
          <li><a cw-href="/emne/energi" class="ng-isolate-scope" href="/emne/energi">Olje/energi</a></li>
          <li><a cw-href="/emne/bygganlegg" class="ng-isolate-scope" href="/emne/bygganlegg">Bygg/anlegg</a></li>
          <li><a cw-href="/emne/offentlig-it" class="ng-isolate-scope" href="/emne/offentlig-it">Offentlig it</a></li>
          <li><a cw-href="/emne/fintech" class="ng-isolate-scope" href="/emne/fintech">Fintech</a></li>
        </ul>
      </nav>
    </div>
  </header>
  <header class="sub-header clearfix">
    <div class="cw-wrapper">
      <nav class="sub-menu">
        <ul>
          <li><a cw-href="/" class="ng-isolate-scope" href="/">Computerworld</a></li>
          <li><a cw-href="/pcworld" class="ng-isolate-scope" href="/pcworld">PC World</a></li>
          <li><a cw-href="/macworld" class="ng-isolate-scope" href="/macworld">Macworld</a></li>
          <li><a cw-href="/it-bransjen" class="ng-isolate-scope" href="/it-bransjen">IT-bransjen</a></li>
          <li><a href="http://www.telecomrevy.no/">Telecom Revy</a></li>
          <li><a href="http://event.cw.no/">Event</a></li>
          <li><a href="http://whitepaper.idg.no/">Whitepaper</a></li>
          <li><a href="http://itjobb.idg.no/">Stilling ledig</a></li>
        </ul>
      </nav>
    </div>
  </header>

  <!-- EXPANDED MENU -->
  <nav class="expanded-menu" ng-click="toggleExpMenu()">
    <!-- ngInclude: '/sites/computerworld/includes/expanded-menu.html' --><div class="l-row ng-scope" ng-include="'/sites/computerworld/includes/expanded-menu.html'">
<div class="menu-container ng-scope" ng-click="$event.stopPropagation()">

  <nav class="menu-content">
    <div class="nf-searchbar ng-hide" ng-show="showExpSearch">
      <form action="/s" class="ng-pristine ng-valid">
        <label for="searchBarTxt" class="visuallyhidden">Søk</label>
        <input id="searchBarTxt" type="text" name="q" placeholder="Søk...">
        <input type="submit" value="" style="display: none;">
        <span class="nf-search-cancel" ng-click="hideExpSearch()">
          <i class="i-cancel"></i>
        </span>
      </form>
    </div>
    <ul>
      <li ng-class="{'open': expMO1}">
        <i ng-click="expMO1=!expMO1"></i>
        <a cw-href="/pcworld" class="ng-isolate-scope" href="/pcworld">PC World</a>
        <ul class="submenu">
          <li><a cw-href="/emne/tester" class="ng-isolate-scope" href="/emne/tester">Tester</a></li>
        </ul>
      </li>
      <li ng-class="{'open': expMO2}">
        <i ng-click="expMO2=!expMO2"></i>
        <a cw-href="/macworld" class="ng-isolate-scope" href="/macworld">Macworld</a>
        <ul class="submenu">
          <li><a cw-href="/emne/tester" class="ng-isolate-scope" href="/emne/tester">Tester</a></li>
        </ul>
      </li>
      <li><a cw-href="/it-bransjen" class="ng-isolate-scope" href="/it-bransjen">IT-bransjen</a></li>
      <li><a href="http://www.telecomrevy.no/">Telecom Revy</a></li>
      <li><a cw-href="/emne/it-helse/" class="ng-isolate-scope" href="/emne/it-helse/">IT-Helse</a></li>
      <li><a cw-href="/emne/it-karriere/" class="ng-isolate-scope" href="/emne/it-karriere/">IT-Karriere</a></li>
      <li><a href="http://event.cw.no/">Event</a></li>
      <li><a href="http://whitepaper.idg.no/">Whitepaper</a></li>
      <li><a href="http://itjobb.idg.no/">Stilling ledig</a></li>
      <li class="open">
        <a cw-href="/om/computerworld" class="ng-isolate-scope" href="/om/computerworld">Om Computerworld</a>
        <ul class="submenu">
          <li><a cw-href="/om/abonnement" class="ng-isolate-scope" href="/om/abonnement">Abonnement</a></li>
          <li><a href="http://medieinfo.cw.no">Medieinformasjon</a></li>
          <li><a cw-href="/om/kontakt" class="ng-isolate-scope" href="/om/kontakt">Kontaktinformasjon</a></li>
          <li><a cw-href="/om/logoer" class="ng-isolate-scope" href="/om/logoer">Logoarkiv</a></li>
        </ul>
      </li>
    </ul>
  </nav>

</div>
</div>
  </nav>

  <!-- USER MENU -->
  <nav class="exp-user-menu" ng-click="toggleUserMenu()">
    <div class="l-row">
      <div class="menu-container" ng-click="$event.stopPropagation()">
        <nav class="menu-content">
          <ul>
            <li ng-show="user" class="ng-hide"><a href="" ng-click="logout()">Logg ut</a></li>
            <li ng-show="user" class="ng-hide"><a href="" ng-click="frontidMyPage()">Min side</a></li>
            <li ng-show="!user" class=""><a href="" ng-click="frontidLogin()">Logg inn</a></li>
            <li ng-show="!user" class=""><a href="" ng-click="frontidRegister()">Registrer deg</a></li>
            <li><a href="" ng-click="frontidRegisterViaPlan()">Bestill abonnement</a></li>
          </ul>
        </nav>
      </div>
    </div>
  </nav>

  <!-- SEARCH BOX -->
  <section class="l-container ng-hide" ng-show="isSearch || searchOpen">
    <header class="search--form">
      <div class="l-row">
        <form id="nf-search-form" class="nf-sbform nf-sbopen ng-pristine ng-valid" ng-submit="$root.search()">
          <label for="nf-search-q" class="visuallyhidden">Søk</label>
          <input id="nf-search-q" type="text" ng-model="$root.q" placeholder="Søk Computerworld..." class="ng-pristine ng-valid">
          <input type="submit" class="with-icon" value="b">
        </form>
      </div>
    </header>
  </section>

  <!-- MAIN CONTENT -->
  <div class="main-content">
    <script type="text/javascript">
      if(navigator.userAgent !== 'NewsPhantom')
        document.write('<scr'+'ipt type="text/javascript" src="http://ad1.emediate.dk/eas?cu=28636;cre=mu;js=y;pageviewid=;target=_blank"></scr'+'ipt>');
    </script>

    <!-- AD "Skyscraper_180x600" -->
    <div class="cw-ad-sidebar x-180-600 ng-isolate-scope" idg-ad="" position="Skyscraper_180x600" mq="(min-width:1215px)"></div>
    <!-- AD "Skyscraper_180x600_2" -->
    <div class="cw-ad-sidebar-left x-180-600 ng-isolate-scope" idg-ad="" position="Skyscraper_180x600_2" mq="(min-width:1396px)"></div>

    <!-- AD "Wallpaper_Ads" -->
    <div class="cw-ad-wall-top ng-isolate-scope" idg-ad="" position="Wallpaper_Top" mq="(min-width:830px)"></div>
    <div class="cw-ad-wall">
      <div class="cw-ad-wall-left ng-isolate-scope" idg-ad="" position="Wallpaper_Left" mq="(min-width:1025px)"></div>
      <div class="cw-ad-wall-right ng-isolate-scope" idg-ad="" position="Wallpaper_Right" mq="(min-width:1025px)"></div>
    </div>

    <!-- ngView:  --><div ng-view="" class="ng-scope">
<!-- ngInclude: '/sites/default/includes/404.html' --><div ng-include="'/sites/default/includes/404.html'" class="ng-scope"><!-- ngIf: notFound -->
</div>

<!-- ngIf: !notFound --><div class="l-container article-wrapper clearfix article-section-mac" ng-if="!notFound">
  <!-- "Mobil_580x400_01" -->
  <div class="l-row mobile-only ad-header-top">
    <div class="ad-responsive x-580-400 ng-isolate-scope" idg-ad="" position="Mobil_580x400_01" responsive="true" target="mobile"></div>
  </div>

  <div class="l-row desktop-only">
    <!-- Services Iframe -->
    <iframe src="http://idgservices.devz.no/widget/jobs-simple" style="width:100%;height:120px;margin-bottom:15px;" scrolling="no"></iframe>
  </div>

  <!-- Full Article content -->

  <div class="l-row">
    <article role="main" class="article" itemtype="http://schema.org/Article" itemscope="">
      <!-- Article Header -->
      <header>
        <!-- <div ng-if="restrict" class="login-overlay">
          <h2>This article is available only to subscribers!</h2>
          <p>Please login to read it.</p>
          <a href="" ng-click="mcLogin()" class="btn-simple">Logg inn</a>
        </div> -->

        <div nf-multi-media="article" options="{imageStyle:'large'}" class="ng-isolate-scope">
<!-- Image -->
<!-- ngIf: article.isImage --><figure class="image main-image ng-scope" ng-if="article.isImage">
  <img itemprop="image" nf-image="article" type="large" class="ng-isolate-scope" alt="Apple fikser Spectre og Meltdown" title="Apple fikser Spectre og Meltdown" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/spectre.png">
  <figcaption ng-show="article.media.image.main.caption || article.image_caption" class="">
    <p ng-bind-html="article.media.image.main.caption || article.image_caption" class="ng-binding">ARM: Alle moderne CPUer rammes (Design:&nbsp;Natascha Eibl (Creative Commons CC0))</p>
  </figcaption>
</figure><!-- end ngIf: article.isImage -->

<!-- Video -->
<!-- ngIf: article.isVideo -->

<!-- Gallery -->
<!-- ngIf: article.isGallery -->

<!-- Map -->
<!-- ngIf: article.isMap -->
</div>

        <h1 itemprop="name headline" ng-bind-html="article.long_title" class="ng-binding">Apple fikser Spectre og Meltdown</h1>
        <div class="teaser ng-binding" ng-bind-html="article.intro || article.teaser">De alvorlige lavnivå-svakhetene i Intels og andres prosessorer har konsekvenser for datamaskiner siden forrige århundre. Apple har tatt grep, og det ser ut til at selskapets produkter ikke vil oppleve de samme ytelsesreduksjonene andre plattformer kommer til å oppleve.</div>

        <div class="byline clearfix">
          <!-- Author sharing -->
          <div class="author">
            <!-- ngIf: extra.mainAuthor.picture --><img ng-src="http://admin.cw.no/sites/default/files/styles/author/public/user-image/picture-802-1426431320.png?itok=LZWXDg3B" ng-if="extra.mainAuthor.picture" class="ng-scope" src="http://admin.cw.no/sites/default/files/styles/author/public/user-image/picture-802-1426431320.png?itok=LZWXDg3B"><!-- end ngIf: extra.mainAuthor.picture -->
            <div class="name ng-binding">Arno Vaa</div>
            <!-- ngIf: extra.mainAuthor.mail --><div class="email ng-scope" ng-if="extra.mainAuthor.mail">
              <a ng-href="mailto:arno@macworld.no?subject=Apple fikser Spectre og Meltdown" target="_blank" class="ng-binding" href="mailto:arno@macworld.no?subject=Apple fikser Spectre og Meltdown">arno@macworld.no</a>
            </div><!-- end ngIf: extra.mainAuthor.mail -->

            <time datetime="2018-01-05" class="ng-binding">
              <span class="label">Publisert:</span> fredag 05. januar 2018, kl.10:14
            </time>
            <time ng-show="article.changed &gt; article.published" datetime="2018-01-05" class="ng-binding">
              <span class="label">Endret:</span> 05. januar 2018, kl.10:37
            </time>
          </div>
          <!-- Byline sharing -->
          <div class="sharing">
            <ul>
              <!-- ngIf: extra.mainAuthor.twitter --><li ng-if="extra.mainAuthor.twitter" class="ng-scope">
                <a ng-href="https://twitter.com/arnovaa" target="_blank" href="https://twitter.com/arnovaa"><i class="i-twitter-circled"></i></a>
              </li><!-- end ngIf: extra.mainAuthor.twitter -->
              <!-- ngIf: extra.mainAuthor.facebook -->
              <li><a href="" ng-click="shareByEmail(article.title)" target="_blank"><i class="i-mail"></i></a></li>
            </ul>
          </div>
        </div>
      </header>

      <div class="l-inner-row">
        <div class="grid-8 article-grid">
          <!-- "Netboard_580x400_Artikkel" -->
          <!-- ngIf: !restrict --><div class="ad-fit-body tabletup-only ng-scope" ng-if="!restrict">
            <div class="x-580-400 ad-responsive ng-isolate-scope" idg-ad="" position="Netboard_580x400_No1" responsive="true" target="tabletup"></div>
          </div><!-- end ngIf: !restrict -->

          <!-- PAYWALL POPUP -->
          <!-- ngIf: restrict -->

          <!-- ARTICLE BODY -->
          <div class="article--body"><div class="field field-name-body field-type-text-with-summary field-label-hidden ng-scope">
    <p>Spectre og Meltdown er kallenavn for alvorlige svikt i sikkerheten til alle moderne prosessorer fra Intel, AMD og også ARM.</p>

<p>Det betyr at de aller fleste datamaskiner og mange mobile enheter rammes, selv om AMDs arkitektur i liten grad er eksponert.&nbsp;</p>

<p>Feilrettingen vil for mange plattformer bety redusert ytelse både på prosessor-nivå og på lese/skrive-nivå til lokal lagring, men Apples egne tester viser i motsetning at Mac og mobile enheter i liten eller ubetydelig grad vil rammes.&nbsp;</p>

<h3>Pentium og fremover</h3>

<p>Svikten finnes helt tilbake til 1990-tallet i Intels Pentium-prosessorer, og eksponerer antatt trygg informasjon på kernel-nivå, slik som passord, til prosesser uten dype rettigheter.</p>

<p>Lokalt installert programvare som er lastet ned fra sikre kilder, slik som Mac AppStore, vil i større grad være til å stole på, men også script som kjøres (ofte usynlig)&nbsp;i nettlesere kan utnytte feilen.&nbsp;</p>

<h3>Dypt der nede</h3>

<p>Det er ikke første gang Intel har slitt med svakheter i maskinvaren sin, og notoriske eksempler inkluderer feil i flyttalls-operasjoner som gjorde at matte-koprosessorene regnet galt.&nbsp;</p>
<div class="tabletup-only left ng-isolate-scope" idg-ad="" position="InlineAd_01" target="tabletup"></div>

<p>Utfordringen er selvfølgelig at oppdateringer til firmware og mikrokode på prosessornivå har begrensete muligheter for å rette feil i selve maskinvaredesignet. Både Meltdown og Spectre har vært kjent i et halvt år, og både Google, Microsoft, Intel og også Apple har arbeidet med å fikse eksponeringen mot disse svakhetene gjennom oppdateringer i programvare.</p>

<h3>macOS og iOS-fiks</h3>

<p>For Apples vedkommende vil alle som har oppdatert macOS til siste release i stor grad være trygge. Også siste iOS-utgave har fått en patch for å styre unna. I tillegg vil det komme ytterligere en macOS-oppdatering, for tiden i beta-test, som også gjør nettleseren Safari trygg(ere) mot <em>script</em>-angrep fra nettet.&nbsp;</p>

<p>Les mere om <em>exploit</em>'ene hos Apple <a href="https://support.apple.com/no-no/HT208394" target="_blank">her</a>, eller på egen hjemmeside <a href="https://meltdownattack.com" target="_blank">her</a>. I tillegg har PCWorld en <a href="https://www.pcworld.com/article/3245606/security/intel-x86-cpu-kernel-bug-faq-how-it-affects-pc-mac.html#tk.rss_all" target="_blank">FAQ</a> og en utdypende artikkel <a href="https://www.pcworld.com/article/3245508/components-processors/intel-responds-to-the-cpu-kernel-bug.html#tk.rss_all" target="_blank">her</a>.</p>
<div class="tabletup-only left ng-isolate-scope" idg-ad="" position="InlineAd_02" target="tabletup"></div>

<p>Sjekk også ut de to videoene nedenfor der <em>Meltdown</em>&nbsp;demonstreres.</p>

<p><iframe allowfullscreen="" frameborder="0" height="360" src="//www.youtube.com/embed/bReA1dvGJ6Y?rel=0" width="640"></iframe></p>

<p><iframe allowfullscreen="" frameborder="0" height="360" src="//www.youtube.com/embed/RbHbFkh6eeE?rel=0" width="640"></iframe></p>
  </div></div>

          <!-- Related article list -->
          <!-- ngIf: extra.related --><div class="related-list ng-scope" ng-if="extra.related">
            <h3>Les Også:</h3>
            <ul>
              <!-- ngRepeat: (k,item) in extra.related --><li ng-repeat="(k,item) in extra.related" class="ng-scope">
                <a ng-href="/artikkel/mobile-enheter/microsoft-bommer-med-arm-windows" class="ng-binding" href="/artikkel/mobile-enheter/microsoft-bommer-med-arm-windows">- Microsoft bommer med ARM-Windows</a>
              </li><!-- end ngRepeat: (k,item) in extra.related --><li ng-repeat="(k,item) in extra.related" class="ng-scope">
                <a ng-href="/artikkel/it-bransjen/apple-kjoper-amd" class="ng-binding" href="/artikkel/it-bransjen/apple-kjoper-amd">- Apple kjøper AMD. Eller?</a>
              </li><!-- end ngRepeat: (k,item) in extra.related --><li ng-repeat="(k,item) in extra.related" class="ng-scope">
                <a ng-href="/artikkel/komponenter/skam-dere-intel" class="ng-binding" href="/artikkel/komponenter/skam-dere-intel">- Skam dere, Intel!</a>
              </li><!-- end ngRepeat: (k,item) in extra.related --><li ng-repeat="(k,item) in extra.related" class="ng-scope">
                <a ng-href="/artikkel/apen-kildekode/macos-kildekode-apnet" class="ng-binding" href="/artikkel/apen-kildekode/macos-kildekode-apnet">macOS-kildekode åpnet</a>
              </li><!-- end ngRepeat: (k,item) in extra.related -->
            </ul>
          </div><!-- end ngIf: extra.related -->

          <!-- Tags -->
          <!-- ngIf: article.tags --><div class="tag-list ng-scope" ng-if="article.tags">
            <h3>Les om:</h3>
            <ul class="tag__list inline">
              <!-- ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/apple" class="ng-binding" href="/emne/apple">Apple</a>
              </li><!-- end ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/intel" class="ng-binding" href="/emne/intel">Intel</a>
              </li><!-- end ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/cpu" class="ng-binding" href="/emne/cpu">CPU</a>
              </li><!-- end ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/arm" class="ng-binding" href="/emne/arm">arm</a>
              </li><!-- end ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/amd" class="ng-binding" href="/emne/amd">amd</a>
              </li><!-- end ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/spectre" class="ng-binding" href="/emne/spectre">spectre</a>
              </li><!-- end ngRepeat: k in article.tags --><li class="tag__item ng-scope" ng-repeat="k in article.tags">
                <a ng-href="/emne/meltdown" class="ng-binding" href="/emne/meltdown">meltdown</a>
              </li><!-- end ngRepeat: k in article.tags -->
            </ul>
          </div><!-- end ngIf: article.tags -->

          <!-- ARTICLE FOOTER -->
          <footer class="l-inner-row">
            <!-- Page slider -->
            <!-- ngIf: pages -->

            <!-- Share box -->
            <div class="sharing">
              <ul class="clearfix">
                <li class="twitter">
                  <a href="" ng-click="shareOnTwitter(article.short_title);"><i class="icon-share-twitter"></i> <span>Tvitre</span></a>
                </li>
                <li class="gplus">
                  <a href="" ng-click="shareOnGplus();"><i class="icon-share-gplus"></i> <span>Google+</span></a>
                </li>
                <li class="facebook">
                  <a href="" ng-click="shareOnFacebook();"><i class="icon-share-facebook"></i> <span>Anbefal</span></a>
                </li>
                <li class="email">
                  <a href="" ng-click="shareByEmail(article.title)"><i class="icon-share-mail"></i> <span>Send artikkel</span></a>
                </li>
                <li class="print">
                  <a href="" ng-click="showPrintDialog()"><i class="icon-share-print"></i> <span>Utskrift</span></a>
                </li>
              </ul>
            </div>

            <!-- Related article box -->
            <!-- ngIf: extra.popular --><div class="related-articles clearfix ng-scope" ng-if="extra.popular">
              <!-- ngRepeat: item in extra.popular --><div class="grid-6 ng-scope" ng-repeat="item in extra.popular">
                <article class="clearfix">
                  <a ng-href="/artikkel/apple/billigere-bytte-av-batteri" href="/artikkel/apple/billigere-bytte-av-batteri">
                    <img nf-image="item" source="main" type="small" class="ng-isolate-scope" alt="Billigere bytte av batteri" title="Billigere bytte av batteri" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/iphone-6s-battery-replacement-hero.png">
                    <h2 class="ng-binding"><strong>Les Også:</strong> Billigere bytte av batteri</h2>
                  </a>
                </article>
              </div><!-- end ngRepeat: item in extra.popular --><div class="grid-6 ng-scope" ng-repeat="item in extra.popular">
                <article class="clearfix">
                  <a ng-href="/artikkel/apple/sjekk-iphone-6s-batteriet" href="/artikkel/apple/sjekk-iphone-6s-batteriet">
                    <img nf-image="item" source="main" type="small" class="ng-isolate-scope" alt="Sjekk iPhone 6s-batteriet" title="Sjekk iPhone 6s-batteriet" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/iphone-serial-number.png">
                    <h2 class="ng-binding"><strong>Les Også:</strong> Sjekk iPhone 6s-batteriet selv</h2>
                  </a>
                </article>
              </div><!-- end ngRepeat: item in extra.popular -->
            </div><!-- end ngIf: extra.popular -->
          </footer>

          <!-- Disqus -->
          <!-- ngIf: !restrict --><div id="disqus_thread" ng-if="!restrict" class="ng-scope"></div><!-- end ngIf: !restrict -->
        </div>


        <!-- SIDEBAR -->
        <!-- ngIf: !restrict --><aside class="grid-4 omega ad-displace-sidebar ng-scope" ng-if="!restrict">
          <!-- Facts box -->
          <!-- ngRepeat: item in extra.facts_box --><div ng-repeat="item in extra.facts_box" ng-class="{'fact-box': item.type === 'fact', 'side-feature': item.type === 'clean'}" class="ng-scope side-feature">
            <h3 ng-show="item.type === 'fact'" ng-bind="item.title" class="ng-binding ng-hide">Sitat</h3>
            <div ng-bind-html="item.body" class="ng-binding"><blockquote>
<p>AppleWatch ikke eksponert</p>
</blockquote>
</div>
          </div><!-- end ngRepeat: item in extra.facts_box -->

          <!-- Quotes (not used) -->
          <!-- ngRepeat: item in extra.quotes -->

          <!-- Product box -->
          <!-- ngRepeat: product in extra.reviews -->

          <!-- Whitepapers Iframe -->
          <div>
            <br>
            <iframe src="http://idgservices.devz.no/widget/whitepaper" style="width:100%;height:200px;margin-top:-15px;margin-bottom:25px;" scrolling="no"></iframe>
          </div>

           <!-- "MPU_300x250_No1" -->
          <div class="ad-center-sidebar x-300-250 ad-responsive tabletup-only ng-isolate-scope" idg-ad="" position="MPU_300x250_No1" responsive="true" target="tabletup"></div>
        </aside><!-- end ngIf: !restrict -->
      </div>
    </article>
  </div>
</div><!-- end ngIf: !notFound -->

<div class="l-container ng-scope">
  <!-- ngIf: firstTag --><div ng-if="firstTag" class="ng-scope">
    <div class="l-row">
      <header class="site-tag-header ng-binding" ng-bind="extra.tags[article.tags[0]].name">Apple</header>
    </div>
    <!-- Desked page (tag) -->
    <div class="cw-grids site-section-" nf-desk-page="tagPage" use-tag="apple" limit="3">
  <!-- Row -->
  <!-- ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/nytt-portal-spill-macos-ios" href="/artikkel/apple/nytt-portal-spill-macos-ios">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Nytt Portal-spill for macOS og iOS" title="Nytt Portal-spill for macOS og iOS" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/24086-31173-bcportal_maincapsule_big-l.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Nytt Portal-spill for macOS og iOS</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Portal Bridge Constructor er et tips for aktivitet mellom slagene nå i romjulen.&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/nytt-portal-spill-macos-ios" class="readmore" href="/artikkel/apple/nytt-portal-spill-macos-ios">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/stasjonaer-pc/alienware-steamos-0">Alienware for SteamOS</a> <span>|</span> <a href="/artikkel/it-bransjen/her-kommer-steam-maskinen">Her kommer Steam-maskinen</a> <span>|</span> <a href="/artikkel/komponenter/mac-game-store-utfordrer-steam">Mac Game Store utfordrer Steam</a> <span>|</span> <a href="/artikkel/it-bransjen/derfor-lykkes-steam">Derfor lykkes Steam</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega tabletup-only" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="ad-responsive x-300-250" idg-ad="26780" responsive="true" position="" target="768up"></div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/nytt-batteri-uten-diskusjon" href="/artikkel/apple/nytt-batteri-uten-diskusjon">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Nytt batteri uten diskusjon" title="Nytt batteri uten diskusjon" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/iphone-battery-100745519-orig.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Nytt batteri uten diskusjon</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apple klargjør: Brukere av iPhone 6 eller senere vil få tilbud om redusert pris for batteribytte – uansett.&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/nytt-batteri-uten-diskusjon" class="readmore" href="/artikkel/apple/nytt-batteri-uten-diskusjon">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/komponenter/3d-print-et-batteri">3D-print et batteri</a> <span>|</span> <a href="/artikkel/apple-far-sin-egen-batteri-skandale">Apple får sin egen batteri-skandale</a> <span>|</span> <a href="/artikkel/mobilitet/apple-avviser-batteri-kritikk">Apple avviser batteri-kritikk</a> <span>|</span> <a href="/artikkel/apple/billigere-bytte-av-batteri">Billigere bytte av batteri</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="fif-container " ng-style="data.containerStyle" style="height: 280px; width: 100%;">
  <iframe ng-src="http://idgservices.devz.no/widget/adverts?type=article&amp;placement=computerworld" scrolling="no" ng-style="data.frameStyle" src="http://idgservices.devz.no/widget/adverts?type=article&amp;placement=computerworld" style="overflow: inherit;"></iframe>
</div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/billigere-bytte-av-batteri" href="/artikkel/apple/billigere-bytte-av-batteri">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Billigere bytte av batteri" title="Billigere bytte av batteri" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/iphone-6s-battery-replacement-hero.png">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Billigere bytte av batteri</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Det ble mye forvirring i oppstyret rundt Apples valg om å styre ytelsen på eldre iPhone-modeller for å forlenge batteritiden, og derfor tilbys det nå redusert pris for å bytte til et nytt original-batteri.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/billigere-bytte-av-batteri" class="readmore" href="/artikkel/apple/billigere-bytte-av-batteri">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/komponenter/3d-print-et-batteri">3D-print et batteri</a> <span>|</span> <a href="/artikkel/apple-far-sin-egen-batteri-skandale">Apple får sin egen batteri-skandale</a> <span>|</span> <a href="/artikkel/mobilitet/apple-avviser-batteri-kritikk">Apple avviser batteri-kritikk</a> <span>|</span> <a href="/artikkel/mobiltelefoner/batteritrobbel-ingen-sikkerhetsrisiko">- Batteritrøbbel ingen sikkerhetsrisiko</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/unnskyldning-fra-apple" href="/artikkel/apple/unnskyldning-fra-apple">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="UNNSKYLD: Apple og Tim Cook har har blitt tvunget til å be om unnskyldning for håndteringen av hastighetsnedsettelsen på iPhone. (Ill.: IDG)" title="UNNSKYLD: Apple og Tim Cook har har blitt tvunget til å be om unnskyldning for håndteringen av hastighetsnedsettelsen på iPhone. (Ill.: IDG)" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/dcx/tim-cook-100066561-orig.png">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Unnskyldning fra Apple</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apple har sett seg nødt til å krype til korset og be brukerne om unnskyldning for at de har satt ned hastigheten på telefonene sine når batteriet begynner å bli svakere.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/unnskyldning-fra-apple" class="readmore" href="/artikkel/apple/unnskyldning-fra-apple">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/klokker-apple-ned-eldre-telefoner" href="/artikkel/apple/klokker-apple-ned-eldre-telefoner">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Klokker Apple ned eldre telefoner?" title="Klokker Apple ned eldre telefoner?" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/supplier_responsibility_worker.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Klokker Apple ned eldre telefoner?</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Selskapet bekrefter forlengelse av batterilevetid på sporadisk bekostning av ytelse for modeller med eldre batterier, alt for å beskytte enkeltkomponenter.&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/klokker-apple-ned-eldre-telefoner" class="readmore" href="/artikkel/apple/klokker-apple-ned-eldre-telefoner">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/mobilitet/apple-lover-batterifiks-til-ios-5-0">Apple lover batterifiks til IOS 5</a> <span>|</span> <a href="/artikkel/infrastruktur/11-tips-bedre-batteritid">11 tips for bedre batteritid</a> <span>|</span> <a href="/artikkel/mobilitet/apple-avviser-batteri-kritikk">Apple avviser batteri-kritikk</a> <span>|</span> <a href="/artikkel/mobiltelefoner/batteritrobbel-ingen-sikkerhetsrisiko">- Batteritrøbbel ingen sikkerhetsrisiko</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios" href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Cisco lanserer bedriftssikkerhetsløsning for iOS" title="Cisco lanserer bedriftssikkerhetsløsning for iOS" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/24051-31078-171214-cisco-l.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Cisco med iOS-sikkerhet for bedrifter</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apples samarbeid med Cisco bærer frukter i form av en ny iOS-app for enterprise-utrulling.​</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios" class="readmore" href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/enterprise/apple-har-mye-vinne-ibm-ikke-fullt-sa-mye">- Apple har mye å vinne. IBM ikke fullt så mye.</a> <span>|</span> <a href="/artikkel/kontrakter-avtaler/altibox-fornyer-med-cisco-0">Altibox fornyer med Cisco</a> <span>|</span> <a href="/artikkel/60-prosent-vekst-cisco-norge">60 prosent vekst i Cisco Norge</a> <span>|</span> <a href="/artikkel/92-terabit-ruter-fra-cisco">92 terabit-ruter fra Cisco</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega tabletup-only" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="ad-responsive x-300-250" idg-ad="26780" responsive="true" position="" target="768up"></div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows -->
</div>

    <div class="l-row">
      <header class="site-tag-header"></header>
    </div>
  </div><!-- end ngIf: firstTag -->

  <!-- Desked page (section) -->
  <!-- ngIf: sectionPage --><div class="cw-grids site-section-mac" ng-if="sectionPage" nf-desk-page="sectionPage" exclude-ads="true" on-results="loadedArticles">
  <!-- Row -->
  <!-- ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/nytt-portal-spill-macos-ios" href="/artikkel/apple/nytt-portal-spill-macos-ios">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="Nytt Portal-spill for macOS og iOS" title="Nytt Portal-spill for macOS og iOS" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/24086-31173-bcportal_maincapsule_big-l.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Nytt <strong>Portal</strong>-spill for macOS og iOS</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Portal Bridge Constructor er et tips for aktivitet mellom slagene nå i romjulen.&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/nytt-portal-spill-macos-ios" class="readmore" href="/artikkel/apple/nytt-portal-spill-macos-ios">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/stasjonaer-pc/alienware-steamos-0">Alienware for SteamOS</a> <span>|</span> <a href="/artikkel/it-bransjen/her-kommer-steam-maskinen">Her kommer Steam-maskinen</a> <span>|</span> <a href="/artikkel/komponenter/mac-game-store-utfordrer-steam">Mac Game Store utfordrer Steam</a> <span>|</span> <a href="/artikkel/it-bransjen/derfor-lykkes-steam">Derfor lykkes Steam</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/billigere-bytte-av-batteri" href="/artikkel/apple/billigere-bytte-av-batteri">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="Billigere bytte av batteri" title="Billigere bytte av batteri" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/iphone-6s-battery-replacement-hero.png">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Billigere bytte av <strong>batteri</strong></h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Det ble mye forvirring i oppstyret rundt Apples valg om å styre ytelsen på eldre iPhone-modeller for å forlenge batteritiden, og derfor tilbys det nå redusert pris for å bytte til et nytt original-batteri.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/billigere-bytte-av-batteri" class="readmore" href="/artikkel/apple/billigere-bytte-av-batteri">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/klokker-apple-ned-eldre-telefoner" href="/artikkel/apple/klokker-apple-ned-eldre-telefoner">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="Klokker Apple ned eldre telefoner?" title="Klokker Apple ned eldre telefoner?" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/supplier_responsibility_worker.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding"><strong>Klokker</strong> Apple <strong>ned</strong> eldre telefoner?</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Selskapet bekrefter forlengelse av batterilevetid på sporadisk bekostning av ytelse for modeller med eldre batterier, alt for å beskytte enkeltkomponenter.&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/klokker-apple-ned-eldre-telefoner" class="readmore" href="/artikkel/apple/klokker-apple-ned-eldre-telefoner">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4-8ad">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-8" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/nytt-batteri-uten-diskusjon" href="/artikkel/apple/nytt-batteri-uten-diskusjon">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="Nytt batteri uten diskusjon" title="Nytt batteri uten diskusjon" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/iphone-battery-100745519-orig.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Nytt batteri <strong>uten diskusjon</strong></h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apple klargjør: Brukere av iPhone 6 eller senere vil få tilbud om redusert pris for batteribytte – uansett.&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/nytt-batteri-uten-diskusjon" class="readmore" href="/artikkel/apple/nytt-batteri-uten-diskusjon">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/unnskyldning-fra-apple" href="/artikkel/apple/unnskyldning-fra-apple">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="UNNSKYLD: Apple og Tim Cook har har blitt tvunget til å be om unnskyldning for håndteringen av hastighetsnedsettelsen på iPhone. (Ill.: IDG)" title="UNNSKYLD: Apple og Tim Cook har har blitt tvunget til å be om unnskyldning for håndteringen av hastighetsnedsettelsen på iPhone. (Ill.: IDG)" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/dcx/tim-cook-100066561-orig.png">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding"><strong>Unnskyldning</strong> fra Apple</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apple har sett seg nødt til å krype til korset og be brukerne om unnskyldning for at de har satt ned hastigheten på telefonene sine når batteriet begynner å bli svakere.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/unnskyldning-fra-apple" class="readmore" href="/artikkel/apple/unnskyldning-fra-apple">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row desktop-only">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid- clearfix omega tabletup-only" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="ad-responsive x-980-300" idg-ad="" responsive="true" position="Superboard_980x300" target="desktop"></div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios" href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="Cisco lanserer bedriftssikkerhetsløsning for iOS" title="Cisco lanserer bedriftssikkerhetsløsning for iOS" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/24051-31078-171214-cisco-l.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Cisco med <strong>iOS-sikkerhet</strong> for bedrifter</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apples samarbeid med Cisco bærer frukter i form av en ny iOS-app for enterprise-utrulling.​</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios" class="readmore" href="/artikkel/apple/cisco-lanserer-bedriftssikkerhetslosning-ios">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/arm-brikke-nye-imac-pro" href="/artikkel/apple/arm-brikke-nye-imac-pro">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="ARM-brikke i nye iMac Pro" title="ARM-brikke i nye iMac Pro" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/audio_state_2_large_2x.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding"><strong>ARM</strong>-brikke i nye iMac Pro</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Apple bekrefter at det sitter en egendesignet T2-chip i den nye proff-modellen. Er vi på vei bort fra Intel til rene ARM-maskiner?&nbsp;</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/arm-brikke-nye-imac-pro" class="readmore" href="/artikkel/apple/arm-brikke-nye-imac-pro">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/endelig-thunderbolt-kabel-fra-apple" href="/artikkel/apple/endelig-thunderbolt-kabel-fra-apple">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="Endelig Thunderbolt-kabel fra Apple" title="Endelig Thunderbolt-kabel fra Apple" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/mq4h2_av2.jpeg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Endelig <strong>Thunder-bolt</strong>-kabel fra Apple</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Det har tatt tid, men nå tilbyr også Apple selv Thunderbolt 3-ledninger som tillater lading med høy effekt.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/endelig-thunderbolt-kabel-fra-apple" class="readmore" href="/artikkel/apple/endelig-thunderbolt-kabel-fra-apple">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row mobile-only">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid- clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="ad-responsive x-580-400" idg-ad="" responsive="true" position="Mobil_580x400_02" target="mobile"></div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row ">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="fif-container " ng-style="data.containerStyle" style="height: 240px; width: 100%;">
  <iframe ng-src="http://idgservices.devz.no/widget/adverts?type=article&amp;placement=computerworld" scrolling="no" ng-style="data.frameStyle" src="http://idgservices.devz.no/widget/adverts?type=article&amp;placement=computerworld" style="overflow: inherit;"></iframe>
</div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-12large">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/iphone-x-ringelyd" href="/artikkel/apple/iphone-x-ringelyd">
    <img nf-image="data" source="landscape" type="large" class="ng-isolate-scope" alt="iPhone X ringelyd" title="iPhone X ringelyd" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_landscape_medium/public/img/iphone-x-gallery3-2017.jpeg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding"><strong>Ringelyden</strong> til iPhone X</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Alle kjenner marimba-melodien fra en ringende iPhone. Men iPhone X-eiere er ikke som andre iPhone-eiere. Hør lyden av «ny mobil» i saken.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/iphone-x-ringelyd" class="readmore" href="/artikkel/apple/iphone-x-ringelyd">Les mer</a>
  </div>

  <!-- ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row ">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="fif-container " ng-style="data.containerStyle" style="height: 80px; width: 100%;">
  <iframe ng-src="http://web.idg.no/app/web/online/nyhetsbrev/macworld/registrering/form.html" scrolling="no" ng-style="data.frameStyle" src="http://web.idg.no/app/web/online/nyhetsbrev/macworld/registrering/form.html" style="overflow: inherit;"></iframe>
</div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row style-4double-8">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-4" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/amazon-prime-pa-apple-tv" href="/artikkel/apple/amazon-prime-pa-apple-tv">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Amazon Prime på Apple TV" title="Amazon Prime på Apple TV" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/apple_tv_4k_marvelous_mrs_maisel_20171206.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Amazon Prime på Apple TV</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Tonnevis av innhold, inkludert 4K-filmer og tv-serier. iOS-appen samtidig oppdatert for iPhone X.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/amazon-prime-pa-apple-tv" class="readmore" href="/artikkel/apple/amazon-prime-pa-apple-tv">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/fotovideo/40000-nrk-programmer-pa-apple-tv">40.000 NRK-programmer på Apple TV</a> <span>|</span> <a href="/artikkel/fotovideo/apple-tv-far-stotte-tastatur">Apple TV får støtte for tastatur</a> <span>|</span> <a href="/artikkel/ny-apple-tv-vil-endre-alt">- Ny Apple TV vil endre alt</a> <span>|</span> <a href="/artikkel/apple-tv-4k">Apple TV 4K</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/apple/nye-remmer-apple-watch" href="/artikkel/apple/nye-remmer-apple-watch">
    <img nf-image="data" source="main" type="small" class="ng-isolate-scope" alt="Nye remmer for Apple Watch" title="Nye remmer for Apple Watch" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/watch-bands-header-hero-201712.png">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">Nye remmer for Apple Watch</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Ypperlig gaveidé til jul. Dessuten: Sjekk ut disse nye AppleWatch promo-videoene.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/apple/nye-remmer-apple-watch" class="readmore" href="/artikkel/apple/nye-remmer-apple-watch">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/apple/apple-lanserer-ny-font-apple-watch">Apple lanserer ny font for Apple Watch</a> <span>|</span> <a href="/artikkel/apple-watch/79-292-kroner-apple-watch-gull">79 292 kroner for Apple Watch i gull</a> <span>|</span> <a href="/artikkel/apple-watch-mest-noyaktig">Apple Watch mest nøyaktig</a> <span>|</span> <a href="/artikkel/apple-watch-med-4g">Apple Watch med 4G</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-8 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <!-- ngIf: data.id --><article ng-if="data.id" class="ng-scope">
  <a ng-href="/artikkel/mobiltelefoner/pa-hoy-tid-med-raskere-iphone-lading" href="/artikkel/mobiltelefoner/pa-hoy-tid-med-raskere-iphone-lading">
    <img nf-image="data" source="main" type="large" class="ng-isolate-scope" alt="På høy tid med raskere Iphone-lading" title="På høy tid med raskere Iphone-lading" src="http://static.cw.newsfront.no/sites/default/files/styles/crop_image_main_medium/public/img/iphone8-charging_dock_front_cwformat.jpg">
    <h2 ng-bind-html="data.title|trustHtml" class="ng-binding">På høy tid med raskere Iphone-lading</h2>
    <p class="teaser ng-binding" ng-show="data.teaser" ng-bind-html="data.teaser|trustHtml">Når Apple nå har lagt ut IOS 11.2, får også Iphone-brukere endelig raskere trådløs lading. På høy tid, mener mange brukere.</p>
  </a>
  <div class="readmore-wrap">
    <!-- ngIf: data.premium -->
    <a ng-href="/artikkel/mobiltelefoner/pa-hoy-tid-med-raskere-iphone-lading" class="readmore" href="/artikkel/mobiltelefoner/pa-hoy-tid-med-raskere-iphone-lading">Les mer</a>
  </div>

  <!-- ngIf: data.related --><div class="related ng-scope ng-binding" ng-if="data.related" ng-bind-html="data.related"><a href="/artikkel/smarttelefon/tradlos-hurtiglader">Trådløs hurtiglader</a> <span>|</span> <a href="/artikkel/apple/iphone-x-fri">iPhone X i det fri</a> <span>|</span> <a href="/artikkel/apple/iphone-x-en-bruksanvisning">iPhone X – en bruksanvisning</a></div><!-- end ngIf: data.related -->
</article><!-- end ngIf: data.id -->
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row mobile-only">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid- clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="ad-responsive x-580-400" idg-ad="" responsive="true" position="Mobil_580x400_03" target="mobile"></div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows --><div ng-repeat="row in rows" class="l-row ">

    <!-- ngIf: row.cssClass==='style-extra-black' -->
    <!-- ngIf: row.cssClass==='style-extra-blue' -->

    <!-- Column -->
    <!-- ngRepeat: col in row.columns --><div ng-repeat="col in row.columns" class="col grid-item grid-12 omega" ng-class="{omega: $last}">
      <!-- Spot -->
      <!-- ngRepeat: spot in col.spots --><div ng-repeat="spot in col.spots" class="spot grid-item small-grid-0 clearfix omega" ng-class="{omega: $last, 'tabletup-only': spot.content.type==='EmediateAd' &amp;&amp; spot.content.target!=='mobile'}">
        <!-- Widget -->
        <div class="fif-container " ng-style="data.containerStyle" style="height: 165px; width: 100%;">
  <iframe ng-src="http://web.idg.no/app/web/online/annonser/dnd/etasje/dnd_include.html" scrolling="no" ng-style="data.frameStyle" src="http://web.idg.no/app/web/online/annonser/dnd/etasje/dnd_include.html" style="overflow: inherit;"></iframe>
</div>
      </div><!-- end ngRepeat: spot in col.spots -->
    </div><!-- end ngRepeat: col in row.columns -->
  </div><!-- end ngRepeat: row in rows -->
</div><!-- end ngIf: sectionPage -->

  <!-- Infinite section -->
  <!-- ngIf: query --><div class="l-container ng-scope ng-isolate-scope" ng-if="query" nf-infinite-scroll="query">
<!-- Bottom list -->
<div class="l-row cw-infinite-list ng-isolate-scope" infinite-scroll="loadMore()" infinite-scroll-distance="0" infinite-scroll-disabled="!infinite || loading || !hasMore">

  <!-- ngRepeat: article in list -->
</div>

<!-- Load more -->
<div class="center" ng-show="!infinite &amp;&amp; hasMore">
  <a href="" ng-click="loadMore(8)" class="btn-simple small soft">Vis flere artikler</a>
</div>
</div><!-- end ngIf: query -->
</div>
</div>
  </div>

  <!-- FOOTER -->
  <footer class="cw-footer cw-wrapper cw-infinite-bottom">
    <div class="l-container">
      <div class="top">
        <ul>
          <li><a cw-href="/om/computerworld" class="ng-isolate-scope" href="/om/computerworld">Om Computerworld Norge</a></li>
          <li><a href="http://medieinfo.cw.no">Medieinformasjon</a></li>
          <li><a cw-href="/om/kontakt" class="ng-isolate-scope" href="/om/kontakt">Kontaktinformasjon</a></li>
          <li><a cw-href="/om/abonnement" class="ng-isolate-scope" href="/om/abonnement">Abonnement</a></li>
          <li><a cw-href="/om/personvern" class="ng-isolate-scope" href="/om/personvern">Personvern og informasjonskapsler</a></li>
        </ul>
      </div>
    </div>
  </footer>

  <script src="/build/jquery.combined.js"></script>
  <!--[if gte IE 9]><!-->
  <script src="/build/angular.combined.js?1511346269"></script>
  <script src="/build/computerworld/newsfront.combined.js?1511346269"></script>
  <!--<![endif]-->


<!-- LeadLander -->
<script type="text/javascript" language="javascript">
  if(window.cwBilag && navigator.userAgent !== 'NewsPhantom') {
    var sf14gv = 27591;
    (function() {
    var sf14g = document.createElement('script'); sf14g.type = 'text/javascript'; sf14g.async = true;
    sf14g.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 't.sf14g.com/sf14g.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sf14g, s);
    })();
  }
</script>
<!-- end LeadLander -->

<!-- Pagefair -->
<script type="text/javascript">
  if(navigator.userAgent !== 'NewsPhantom') {
    (function() {
      function async_load(script_url){
          var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
          var s = document.createElement('script'); s.src = protocol + script_url;
          var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
      }
      bm_website_code = '822A677AF5764CBA';
      jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
      jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
    })();
  }
</script>
<!-- end Pagefair -->



<iframe id="frontid-iframe" src="https://pay.frontkom.no/logged_in?referer_url=http://www.cw.no/artikkel/apple/apple-fikser-spectre-meltdown" style="display: none;"></iframe></body></html>
