Apple tetter kritisk iOS-hull

Apple tetter kritisk iOS-hull

Fikser alvorlig sikkerhetsfeil som gjorde det mulig å låse opp iPhone via nettleseren.

Den siste uken har det blitt skrevet mye om det kritiske sikkerhetshullet i iOS som gjør det mulig for hackere å få tilgang til din iPhone, iPod touch og iPad enkelt via nettleseren.

Som lovet har imidlertid Apple nå kommet med en ekstra oppdatering for å tette hullet. iOS 4.0.2 er tilgjengelig for iPhone og iPod touch, mens iOS 3.2.2 er den aktuelle oppdateringen for iPad.

Les også:

Apple skal tette jailbreak-hullet

Inn via pdf

Sikkerhetsfiksen tar hånd om en feil i pdf-systemet som gjør at en ondsinnet pdf-fil kan kjøre systemkode. Det andre hullet gjør det mulig å bruke denne koden for å oppnå økte brukerrettigheter, slik at både applikasjoner og selve operativsystemet kan utnyttes.

De to sårbarhetene ble først funnet av hackere, som kombinerte de to for å lage en såkalt jailbreak av iOS-enheter via nettleseren.

Samtidig som det er bra at skumle iPhone-hull fikses, kommer Apple muligens til å bli kritisert for at de nok en gang "låser inne" brukerne sine. Oppdateringen tar nemlig livet av den svært enkle iPhone-opplåsingen via nettsiden jailbreakme.com.

Start iTunes

Begge oppdateringene kan lastes ned ved at man kobler sin respektive enhet mot iTunes.

iOS 4.0.2 er kompatibel med iPhone 3G, iPhone 3GS, iPhone 4, eller andre- og tredjegenerasjons iPod touch og iOS 4.0 eller senere; iOS 3.2.2 er kompatibel med iPad og iOS 3.2 eller senere. iOS 4 kommer for øvrig til iPad i løpet av høsten.