Nettbanktrøbbel for Mac-brukere

Nettbanktrøbbel for Mac-brukere

Apple sperrer for Java i nettleseren Safari igjen.

Problemene med Java vil ingen ende ta. Til tross for at Oracle har tettet det alvorlige sikkerhetshullet oppdaget i forrige måned, har Apple nå valgt å blokkere tilleggsprogrammet i sin nettleser på Mac igjen.

Det var for noen uker siden at Apple valgte å blokkere alle versjoner av Java eldre enn 1.7.10.19 i Safari på OS X Snow Leopard, Lion og Mountain Lion. Det ble nemlig oppdaget en feil som var så alvorlig at myndighetene i flere land valgte å gå ut med en advarsel mot det.

Avventer ny Java-oppdatering

Nå kommer meldingen om at Apple har valgt å sperre alle versjoner opptil 1.7.11.31, noe som trolig henger sammen med rapporter om at Oracle ikke har klart å få bukt med sikkerhetsproblemene likevel, skriver Macworld Sverige.

Saken er bare den at versjon 1.7.11.21 er den nyeste versjonen av Java. Ifølge Macworld.se er det ingen som vet når 1.7.11.22 kommer. Det skaper trøbbbel for brukere som trenger å kjøre Java i nettleseren de nærmeste dagene.

Trøbbel med BankID og nettbank

I Norge er dette problematisk, spesielt for bankkunder, ettersom en del nettbanker benytter seg av BankID-løsningen som krever Java. BankID anbefaler på sin side Mac-brukere om å benytte seg av nettleseren Firefox for å bruke deres løsning.

Våre kolleger i danske Computerworld skriver dessuten at Mozilla som standard nå har blokkert for tilleggsprogrammer som Java i Firefox, så det er ikke sikkert at dette vil fungere.

I tillegg merker vi oss at selv om Apple nå har blokkert for Java, så får vi det fremdeles til å fungere Safari på våre maskiner. Dette ser imidlertid ut til å variere fra bruker til bruker.

Hvorvidt Apples nyeste tiltak er bra eller ikke er det delte meninger om, ifølge svenske Macworld. Noen mener det er bra selskapet setter sikkerheten først, mens andre mener det er brukeren selv som skal få bestemme hvilke programmer som skal kjøres og ikke.

Sikkerhet